华为oj初级 公共子串

描述
题目标题:
计算两个字符串的最大公共字串的长度,字符不区分大小写
详细描述:
接口说明
原型:
int getCommonStrLength(char * pFirstStr, char * pSecondStr);
输入参数:
char * pFirstStr //第一个字符串
char * pSecondStr//第二个字符串

知识点 字符串,查找
运行时间限制 10M
内存限制 128
输入
输入两个字符串
输出
输出一个整数
样例输入 asdfas werasdfaswer
样例输出 6

#include<iostream>    
#include<string>    
using namespace std;    
int main()    
{    
    string str1,str2,temp;    
    int m,MaxNum=0,Len;    
    cin>>str1>>str2;    
    string::size_type index1;    
    string::size_type index2;    
    for(index1=0;index1!=str1.size();++index1)    
    {    
        str1[index1]=tolower(str1[index1]);    
    }    
    for(index2=0;index2!=str2.size();++index2)    
    {    
        str2[index2]=tolower(str2[index2]);    
    }    
    for(int j=1;j<=str1.size();++j)    
    {    
        for(int i=0;i!=str1.size();++i)    
        {    
            if(i+j<=str1.size())    
            {    
                temp=str1.substr(i,j);    
                m=str2.find(temp);    
                if(m!=string::npos)    
                {    
                    Len=temp.size();    
                    if(Len>MaxNum)    
                        MaxNum=Len;    
                }    

            }    
        }    
    }    
    cout<<MaxNum;    
    return 0;    
}   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值