华为oj初级 进制转换

描述
写出一个程序,接受一个十六进制的数值字符串,输出该数值的十进制字符串。
知识点 字符串,循环,函数,指针
运行时间限制 10M
内存限制 128
输入
输入一个十六进制的数值字符串。
输出
输出该数值的十进制字符串。
样例输入 0xA
样例输出 10

#include<iostream>    
#include<vector>    
#include<string>    
#include<algorithm>  
#include<cmath>  

using namespace std;

int main(){
    string s;
    cin >> s;
    int sum = 0, base = 1;
    int len = s.size();
    for (int i = len - 1; i>1; i--){
        if (islower(s[i])) {
            sum += (s[i] - 87)*base;
            base = base * 16;
        }
        else if (isupper(s[i])){
            sum += (s[i] - 55)*base;
            base = base * 16;
        }
        else if (isdigit(s[i])){
            sum += (s[i] - '0')*base;
            base = base * 16;
        }


    }
    cout << sum;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值