述
Catcher是MCA国的情报员,他工作时发现敌国会用一些对称的密码进行通信,比如像这些ABBA,ABA,A,123321,但是他们有时会在开始或结束时加入一些无关的字符以防止别国破解。比如进行下列变化 ABBA->12ABBA,ABA->ABAKK,123321->51233214 。因为截获的串太长了,而且存在多种可能的情况(abaaab可看作是aba,或baaab的加密形式),Cathcer的工作量实在是太大了,他只能向电脑高手求助,你能帮Catcher找出最长的有效密码串吗?
样例输入:
ABBA
12ABBA
A
ABAKK
51233214
abaaab
样例输出:
4
4
1
3
6
5
可以使用中提供的库函数。
实现接口,每个接口实现1个基本操作:
voidGetCipherMaxLen(characCipherContent[],int *piCipherLen):
acCipherContent是一个字符串数组常量,见参考用例;
piCipherLen为输出有效密码串的最大长度;
题目框架中有2个参考用例,其它用例请执行编写。
知识点 字符串
运行时间限制 10M
内存限制 128
输入
输入一串字符
输出
输出有效长度
样例输入 ABBA
样例输出 4
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<unordered_map>
#include<fstream>
#include<sstream>
#include<queue>
#include<stack>
using namespace std;
int main(){
string s;
string s1, s2;
while (cin >> s){
int maxLen = 0;
for (int i = 0; i < s.size(); i++){
for (int j = s.size()-1; j>=i; j--){
s1 = s.substr(i, j + 1);
s2 = s1;
reverse(s2.begin(),s2.end());
if (s1 == s2){
if (s1.size()>maxLen){
maxLen = s1.size();
break;
}
}
}
}
cout << maxLen << endl;
}
return 0;
}
//转载他人
#include<iostream>
#define MAX 10000
using namespace std;
#define min(a,b) ((a)<(b)?(a):(b))
//返回最大回文子串长度,
//输入:原字符串数组指针
//返回值:最大回文子串
int manacher(char *p)
{
char s[MAX << 1] = "$#";
int v[MAX << 1] = { 0 };
int c = 1;
//初始化
while (*p)
{
s[++c] = *p++;
s[++c] = '#';
}
s[++c] = ' ';
int re = 0, mx = 0, cn = 0;
int i;
for (i = 1; s[i] != ' ';i++)
{
if (mx > i)
{
v[i] = min(v[cn * 2 - 1], mx - i);
}
else
v[i] = 1;
while (s[i+v[i]] == s[i-v[i]])
{
++v[i];
}
if (v[i] + i > mx)
{
mx = v[i] + i;
cn = i;
}
if (v[i]>re)
{
re = v[i];
}
}
return re - 1;
}
void test()
{
char s[MAX];
while(cin >> s)
{
int result;
result = manacher(s);
cout << result << endl;
}
}
int main()
{
test();
return 0;
}