杭电ACM 1865 listing

                                            1sting

Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 
Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output

The output contain n lines, each line output the number of result you can get .
 

Sample Input

  
  
3 1 11 11111
 

Sample Output

  
  
1 2 8

 

题目分析:

通过找规律可知这是关于Fibonacci的题,f(0)=1;f(1)=1;f(2)=2;f(3)=3;f(4)=5;f(5)=8;f(6)=13...... ,题目要求至少求到第200个Fibonacci数,比较大,所以要用到大数加法

AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int fib[210][1010];
void fibonacci()         //打表法将前0—200的Fibonacci数都列出来(用大数加法)
{
     int i,j,a;
     fib[0][0]=1;
     fib[1][0]=1;
     for(i=2;i<=200;i++)
     {
     for(j=0;j<1000;j++)
     {
     a=fib[i][j]+fib[i-1][j]+fib[i-2][j];
     fib[i][j]=a%10;
     fib[i][j+1]=fib[i][j+1]+a/10;
     }
     }
}
int main()
{  
    fibonacci();
    int n,len,i;
    char str[210];
    scanf("%d",&n);
    getchar();
    while(n--)
    {
         scanf("%s",str);
         getchar();
         len=strlen(str);
         if(len==0)
         printf("1\n");
         else if(len==1)
         printf("1\n");
         else
         {
         for(i=999;i>=0&&fib[len][i]==0;i--) ;           //消除前面多余的0
         for(;i>=0;i--)
         printf("%d",fib[len][i]);
         printf("\n");
         }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值