Elven Postman

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods. 

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture. 

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited. 

Your task is to determine how to reach a certain room given the sequence written on the root. 

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree. 

Input

First you are given an integer T(T≤10)T(T≤10) indicating the number of test cases. 

For each test case, there is a number n(n≤1000)n(n≤1000) on a line representing the number of rooms in this tree. nn integers representing the sequence written at the root follow, respectively a1,...,ana1,...,an where a1,...,an∈{1,...,n}a1,...,an∈{1,...,n}. 

On the next line, there is a number qq representing the number of mails to be sent. After that, there will be qq integers x1,...,xqx1,...,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (EE or WW) the postman needs to make to deliver the mail. For that EE means that the postman should move up the eastern branch and WW the western one. If the destination is on the root, just output a blank line would suffice. 

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output

E

WE
EEEEE

题意:给一个搜索二叉树,再给出几个数,找出它们的位置。

思路:先构造一个搜索二叉树,之后去查找。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
struct node//一个结点包含结点里的值v和左右子树
{
    int v;
    node *left,*right;//定义结构体指针
};

node *insert(node *p,int x)//将x插入树,*p指向总树根的位置,返回结构体指针型.另:*放在哪有几个空格都没关系
{
    if(p==NULL)//如果没有值
    {
        node *q=new node;//申请一个新的结点的空间,大小就是结构体的大小
        q->v=x;//将x赋给根
        q->left=q->right=NULL;//初始化左右子树
        return q;
    }
    else
    {
        if(x<p->v) p->left=insert(p->left,x);//如果x小于根的值则存入左子树
        else p->right=insert(p->right,x);//如果x大于根的值则存入右子树
        return p;
    }
}

void find(node *p,int x)
{
    if(p==NULL) return;
    else if(x==p->v) return;//如果在根上找到了值则什么都不输出
    else if(x<p->v) {printf("E");find(p->left,x);}//如果在左子树上找到了值则输出E
    else if(x>p->v) {printf("W");find(p->right,x);} //如果在右子树上找到了则输出W
}
int main()
{
    int t,n,m,x,y;
    scanf("%d",&t);
    while(t--)
    {
        node *root=NULL;//申请一个空间指向总根
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            root=insert(root,x);//root只是记录总树根,理解为这个指针指向这棵树的树根
        }
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d",&y);
            find(root,y);
            printf("\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值