Friend Numbers (20)

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them. Note: a number is considered a friend of itself.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26
写完后感觉自己做复杂了,可以使用set类,因为set类是有序且不重复的。自己的解法需要注意迭代器的使用,以及unique函数会返回第一个重复元素的迭代器。

//
//  main.cpp
//  friend_id
//
//  Created by Hui Du on 2017/9/15.
//  Copyright © 2017年 Hui Du. All rights reserved.
//

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;


#define limit 10000


vector<int> friend_id;
int calculate(int n){
    int sum = 0;
    sum = n / limit; //10 000
    n = n % 10000;
    sum += n / 1000;
    n = n % 1000;
    sum += n / 100;
    n = n % 100;
    sum += n /10;
    n = n % 10;
    sum += n;
    return sum;
}


int main()
{
    int num, test_num;
    int id;
    cin >> num;
    while(num--){
        cin >> test_num;
        id = calculate(test_num);
        friend_id.push_back(id);
    }
    sort(friend_id.begin(), friend_id.end(), less<int>());//排序函数;
    //unique(friend_id.begin(), friend_id.end());//unique函数返回第一个重复元素的迭代器;
    friend_id.erase(unique(friend_id.begin(), friend_id.end()),friend_id.end());//使用迭代器删除重复元素,

    cout << friend_id.size() << endl;
    int size = (int)friend_id.size();
    for(int j = 0; j < size; j++){
        cout << friend_id[j];
        if(j != size -1){
            cout << " ";
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值