Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print “None” instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
由于时间限制,曾尝试使用结构体多次循环,结果超时,更换成map储存接收数据和出现次数后成功AC
//
// main.cpp
// BeUnique
//
// Created by Hui Du on 2017/10/18.
// Copyright © 2017年 Hui Du. All rights reserved.
//
#include <iostream>
#include <cstdio>
#include <map>
#include <time.h>
#include <vector>
#define maxn 100005;
using namespace std;
int main(int argc, const char * argv[]) {
int N;
map<int, int> numsMap;
cin >> N;
vector<int> nums;
int num;
for(int i = 0; i < N ; i++){
cin >> num;
numsMap[num]++;//若该数曾经出现过,则增加计数器
nums.push_back(num);//存储数据
}
num = 0;
for(int i = 0; i<nums.size(); i++){
if(numsMap[nums[i]] == 1){
num = nums[i];
break;
}
}
if(num != 0){
cout << num << endl;
} else cout << "None\n";
//cout << "Totle Time : " << (double)clock() /CLOCKS_PER_SEC<< "s" << endl;
return 0;
}