UVa-232

A crossword puzzle consists of a rectangular grid of black andwhite squares and two lists of definitions (or descriptions).


One list of definitions is for “words” to be written left toright across white squares in the rows and the other list is forwords to be written down white squares in the columns. (Aword is a sequence of alphabetic characters.)

To solve a crossword puzzle, one writes the words correspondingto the definitions on the white squares of the grid.

The definitions correspond to the rectangular grid bymeans of sequential integers on “eligible” white squares.White squares with black squares immediately to the left orabove them are “eligible.” White squares with no squares eitherimmediately to the left or above are also “eligible.” No other squares are numbered. All of thesquares on the first row are numbered.

The numbering starts with 1 and continues consecutively across white squares of the first row, thenacross the eligible white squares of the second row, then across the eligible white squares of the thirdrow and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangularcrossword puzzle grid with appropriate numbering.

An “across” word for a definition is written on a sequence of white squares in a row starting on anumbered square that does not follow another white square in the same row.

The sequence of white squares for that word goes across the row of the numbered square, endingimmediately before the next black square in the row or in the rightmost square of the row.

A “down” word for a definition is written on a sequence of white squares in a column starting on anumbered square that does not follow another white square in the same column.

The sequence of white squares for that word goes down the column of the numbered square, endingimmediately before the next black square in the column or in the bottom square of the column.

Every white square in a correctly solved puzzle contains a letter.

You must write a program that takes several solved crossword puzzles as input and outputs the listsof across and down words which constitute the solutions.


Input

Each puzzle solution in the input starts with a line containing two integers r and c (1 ≤ r ≤ 10 and1 ≤ c ≤ 10), where r (the first number) is the number of rows in the puzzle and c (the second number)is the number of columns.

The r rows of input which follow each contain c characters (excluding the end-of-line) which describethe solution. Each of those c characters is an alphabetic character which is part of a word or thecharacter ‘*’, which indicates a black square.

The end of input is indicated by a line consisting of the single number ‘0’.


Output

Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and thelist of across words followed by the list of down words. Words in each list must be output one-per-linein increasing order of the number of their corresponding definitions.

The heading for the list of across words is ‘Across’. The heading for the list of down words is ‘Down’.In the case where the lists are empty (all squares in the grid are black), the ‘Across’ and ‘Down’headings should still appear.Separate output for successive input puzzles by a blank line


Sample Input

2 2

AT

*O

6 7

AIM*DEN

*ME*ONE

UPON*TO

SO*ERIN

*SA*OR*

IES*DEA0


Sample Output

puzzle #1:

Across

1.AT

3.O

Down

1.A

2.TO


puzzle #2:

Across

1.AIM

4.DEN

7.ME

8.ONE

9.UPON

11.TO

12.SO

13.ERIN

15.SA

17.OR

18.IES

19.DEA

Down

1.A

2.IMPOSE

3.MEO

4.DO

5.ENTIRE

6.NEON

9.US

10.NE

14.ROD

16.AS

18.I

20.A


思路:开两个数组,分别存字母和数字。当左边为边界或*时横向输出,当上边为边界或*时纵向输出。

下列代码转载自:http://www.cnblogs.com/mu-ye/p/5467921.html

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

int main()
{
	int m, n, t = 0;
	while (cin >> m&&m)
	{
		cin >> n;
		if (t)cout << endl;
		char a[10][10];
		int b[10][10];
		memset(b, 0, sizeof(b));
		for (int i = 0; i<m; i++)
		{
			for (int j = 0; j<n; j++)
			{
				cin >> a[i][j];
			}
		}
		int cnt = 0;
		for (int i = 0; i<m; i++)//在另一个整形二维数组中编号
		{
			for (int j = 0; j<n; j++)
			{
				if (a[i][j] == '*')
				{
					b[i][j] = -1;
				}
				if (b[i][j] >= 0)
				{
					if (!i || !j)
					{
						cnt++;
						b[i][j] = cnt;
					}
					else
					{
						if (a[i][j - 1] == '*' || a[i - 1][j] == '*')
						{
							cnt++;
							b[i][j] = cnt;
						}
					}
				}
			}
		}
		cout << "puzzle #" << ++t << ":" << endl;
		cout << "Across" << endl;
		for (int i = 0; i<m; i++)//横向的
		{
			for (int j = 0; j<n; j++)
			{
				if ((j == 0 || b[i][j - 1] == -1) && b[i][j] >= 0)
				{
					printf("%3d.", b[i][j]);
					for (int k = j; k<n; k++)
					{
						cout << a[i][k];
						if (b[i][k + 1] == -1 || k + 1 == n)
						{
							cout << endl;
							break;
						}
					}
				}
			}
		}
		cout << "Down" << endl;
		for (int i = 0; i<m; i++)//纵向的
		{
			for (int j = 0; j<n; j++)
			{
				if ((i == 0 || b[i - 1][j] == -1) && b[i][j] >= 0)
				{
					printf("%3d.", b[i][j]);
					for (int k = i; k<m; k++)
					{
						cout << a[k][j];
						if (b[k + 1][j] == -1 || k + 1 == m)
						{
							cout << endl;
							break;
						}
					}
				}
			}
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值