Pat(A) 1070. Mooncake (25)

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1070

1070. Mooncake (25)


Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

解题报告

题目大意是给出月饼种数和可供库存量,接着给出每一种的吨数和每一种的价格(相对于该吨位的),求库存允许的情况下多能得到的最大收益。
需要注意的是
1. 吨位又可能是非整数
1. 最终的库存可能不满

解决方案就是先读入数据,计算每种月饼的单价,根据单价排序,然后依次遍历月饼,计算收益。

代码

#include "iostream"
#include "vector"
#include "algorithm"

using namespace std;

struct mooncake{
    double tons;
    double price;
    double aver;
};

bool comp(const mooncake &a,const mooncake &b){
    return a.aver>b.aver;
}

int main(){
    int n,d;
    cin>>n>>d;
    vector<mooncake> mc;
    int i;
    for (i = 0; i < n; i ++){
        mooncake x;
        cin>>x.tons;
        mc.push_back(x);
    }
    for (i = 0; i < n; i ++){
        cin>>mc[i].price;
        mc[i].aver = mc[i].price/mc[i].tons;
    }
    sort(mc.begin(),mc.end(),comp);
    i = 0;
    double profit = 0;
    while (d && i<n){
        if(d <= mc[i].tons){
            profit += d * mc[i].aver;
            d = 0;
        }else{
            d -= mc[i].tons;
            profit += mc[i].price;
            i ++;
        }
    }
    printf("%.2f",profit);
    //system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值