程序设计基础47 PAT A1070

1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

一,关于如何把数值加到正确的位置

我当初是采取加的策略,如果加超了就再退回,但这样写程序的健壮性差。

#include<cstdio>
#include<algorithm>
using namespace std;
const int max_n = 1050;
struct MoonCake {
	int amount;
	double total;
	double ave;
}mooncake[max_n];
bool cmp(MoonCake A, MoonCake B) {
	return A.ave > B.ave;
}
int main() {
	int N = 0, D = 0;
	int pos = 0, sum = 0;
	double ans = 0;
	scanf("%d %d", &N, &D);
	for (int i = 0; i < N; i++) {
		scanf("%d", &mooncake[i].amount);
	}
	for (int i = 0; i < N; i++) {
		scanf("%lf", &mooncake[i].total);
		mooncake[i].ave = mooncake[i].total / mooncake[i].amount;
	}
	sort(mooncake, mooncake + N, cmp);
	for (; pos < N; pos++) {
		if (sum < D) {
			sum += mooncake[pos].amount;
			ans += mooncake[pos].total;
		}
		else {
			break;
		}
	}
	if(sum==D){
		printf("%.2f", ans);
	}
	else {
		pos--;
		ans -= mooncake[pos].total;
		sum -= mooncake[pos].amount;
		ans += (D - sum)*mooncake[pos].total / mooncake[pos].amount;
		printf("%.2f", ans);
	}
	return 0;
}

最好的方法是在总的库存量基础上采用减的策略,减到不足下一种月饼的库存量的时候, 直接用这个库存量乘以单价即可。

#include<cstdio>
#include<algorithm>
using namespace std;
const int max_n = 1050;
struct MoonCake {
	double amount;
	double total;
	double ave;
}mooncake[max_n];
bool cmp(MoonCake A, MoonCake B) {
	return A.ave > B.ave;
}
int main() {
	int N = 0, D = 0;
	scanf("%d %d", &N, &D);
	for (int i = 0; i < N; i++) {
		scanf("%lf", &mooncake[i].amount);
	}
	for (int i = 0; i < N; i++) {
		scanf("%lf", &mooncake[i].total);
		mooncake[i].ave = mooncake[i].total / mooncake[i].amount;
	}
	sort(mooncake, mooncake + N, cmp);
	double ans = 0;
	for (int i = 0; i < N; i++) {
		if (mooncake[i].amount <= D) {
			D -= mooncake[i].amount;
			ans += mooncake[i].total;
		}
		else {
			ans += mooncake[i].ave*D;
			break;
		}
	}
	printf("%.2f", ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值