Pat(A) 1087. All Roads Lead to Rome (30)

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1087

1087. All Roads Lead to Rome (30)


Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<=N<=200), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N-1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format “City1 City2 Cost”. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommended. If such a route is still not unique, then we output the one with the maximum average happiness – it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommended route. Then in the next line, you are supposed to print the route in the format “City1->City2->…->ROM”.

Sample Input:
6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1
Sample Output:
3 3 195 97
HZH->PRS->ROM

题目大意

条条大路通罗马,给N个城市,K条线路和出发城市。
每个城市有个happiness,每条路之间也有花费。现让选出一条路,使得花费最少,如果存在花费相同的,选择总happiness最高的,如果再相同,选择平均happiness最高的。

解题报告

标准的DFS深搜解决了,因为城市是三个英文字符,转化成数字,用了两个map,city2id和id2city。
需要注意的就是给的路径是双向的了。

代码

#include "iostream"
#include "vector"
#include "map"
#include "string"
using namespace std;

int N,K;
string startCity;
map<string,int> city2id;
map<int,string> id2city;
vector<int> happiness;
int G[200 + 5][200 + 5];
vector<int> routes;
vector<bool> visited;
int numOfRoutes,cost,happ,numOfCity;
int tempCost = 0,tempHapp = 0,tempNumOfCity = 1;
vector<int> tempRoutes;


void init(){
    cin>>N>>K>>startCity;
    happiness.resize(N);
    routes.resize(N);
    visited.resize(N,false);
    tempRoutes.resize(N);
    numOfCity = cost = happ = numOfCity = 0;
    int i;
    city2id[startCity] = 0;
    id2city[0] = startCity;
    string city;
    int h;
    for(i = 1; i < N; i++){
        cin>>city>>h;
        city2id[city] = i;
        id2city[i] = city;
        happiness[i] = h;
    }
    string city2;//下面用的变量应该是出发城市,到达城市和花费的,节省一点变量,直接用上面的了。
    for(i = 0; i < K; i++){
        cin>>city>>city2>>h;
        cost += h;
        G[city2id[city]][city2id[city2]] = h;
        G[city2id[city2]][city2id[city]] = h;
    }
}

void dfs(int city){
    if(city == city2id[string("ROM")]){
        if(tempCost<cost){
            numOfRoutes = 1;
            happ = tempHapp;
            cost = tempCost;
            numOfCity = tempNumOfCity;
            for(int i = 0; i<= numOfCity; i++){
                routes[i] = tempRoutes[i];
            }
        }else if(tempCost == cost){
            numOfRoutes ++;
            if(tempHapp > happ){
                happ = tempHapp;
                numOfCity = tempNumOfCity;
                for(int i = 0; i<= numOfCity; i++){
                    routes[i] = tempRoutes[i];
                }
            }else if(tempHapp == happ && tempNumOfCity < numOfCity){
                numOfCity = tempNumOfCity;
                for(int i = 0; i<= numOfCity; i++){
                    routes[i] = tempRoutes[i];
                }
            }

        }
        return;
    }
    for(int i = 1; i < N; i++){
        if(!visited[i] && G[city][i]){
            tempCost += G[city][i];
            tempHapp += happiness[i];
            tempNumOfCity ++;
            tempRoutes[tempNumOfCity] = i;
            visited[i] = true;
            dfs(i);
            visited[i] = false;
            tempCost -= G[city][i];
            tempHapp -= happiness[i];
            tempNumOfCity --;
        }
    }
}

void print_G(){
    int i,j;
    for(i = 0;i < N; i++)
        cout<<"\t"<<i;
    cout<<endl;
    for(i = 0;i < N; i++)
        cout<<"-------\t";
    cout<<endl;
    for(i = 0; i < N; i++){
        cout<<i<<"|";
        for(j=0; j < N; j++)
            cout<<"\t"<<G[i][j];
        cout<<endl;
    }

}

int main(){
    init();
    //print_G();
    tempNumOfCity = 0;
    tempRoutes[0] = 0;
    visited[0] = true;
    dfs(0);
    printf("%d %d %d %d\n",numOfRoutes,cost,happ,happ/numOfCity);
    for(int i = 0; i < numOfCity; i++)
        cout<<id2city[routes[i]]<<"->";
    cout<<"ROM"<<endl;
    //system("pause");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值