HDU 1021 Fibonacci Again(找规律)

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50903    Accepted Submission(s): 24098


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

Author
Leojay


题解:取模的题还是找规律,容易知,此题的结果为以8为周期的序列,通过求出前8个的结果也就知道了结果.
再对结果对3取模后,发现结果也有规律,也是个循环序列,前两个除外,此时便找到了一个更加好的方法.

AC代码:

#include<iostream>
using namespace std;
int a[10];
int main()
{
    a[0]=1,a[1]=11;
    int n;
    for(int i=2;i<8;i++)
    {
        a[i]=(a[i-1]+a[i-2]);
    }
    while(cin>>n)
    {
        if((a[n%8])%3==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}

AC代码2(优化版)

#include <iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        if((n+2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值