GPA

Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.

Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message “Unknown letter grade in input” will be printed.

Sample Input
A B C D F
B F F C C A
D C E F

Sample Output
2.00
1.83
Unknown letter grade in input

我来说一下题目的大意吧,
就是ABCDF依次表示43210,
然后把一行输入的(A,B,C,D,F)这个集合里面的加一起算出平均值
如果不是在这个集合里面的,就输入Unknown letter grade in input
这里应该属于属于一直循环的那种

#include<stdio.h>
#include<string.h>   //因为后面用了strlen这个函数
int main(){
    int t,sum0,sum1,sum2;
    char a[1000];   //建立一个字符串数组
    while(gets(a)){  //gets函数接受到'\n'这个键结束,回车键不会被保存
        sum0=0;sum1=0;sum2=0;
        t=strlen(a);
        for(int i=0;i<t;i++){

            if(a[i]=='A')
            sum0+=4;
            else if(a[i]=='B')
            sum0+=3;
            else if(a[i]=='C')
            sum0+=2;
            else if(a[i]=='D')
            sum0+=1;
            else if(a[i]=='F')
            sum0+=0;

            else if(a[i]==' ')
            continue;
            else{
            sum1=1;   //做一个标记
            break;    //我第一遍的时候这个没有加break
            }
            sum2++;


        }
        if(sum1==1)  
        printf("Unknown letter grade in input\n");
        else 
        printf("%.2f\n",(float)sum0/sum2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值