数星星-树状数组(POJ2352)

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input

5
1 1
5 1
7 1
3 3
5 5
Sample Output

1
2
1
1
0
题目大意:
给出一些星星的横坐标和纵坐标,横纵坐标范围不超过32000,星星个数不超过15000,而且星星的纵坐标按非递减排列,如果纵坐标相等,则横坐标按递增排列,任意两颗星星不会重合。如果有n颗星星的横坐标比某颗星星小而且纵坐标不大于那颗星星(即有n颗星星位于那颗星星的左下角或者左边)则此星星的等级为n,最后输出等级为0至n-1的星星的数量。

题解:星星个数和横纵坐标都比较大,采用树状数组来完成。
星星的坐标输入是纵坐标非递减,只需要一维树状数组就行。

代码如下:

#include<cstdio>
using namespace std;
#define maxn 32010
#define lowbit(x) (x)&(-x)
int ans[maxn],c[maxn];//等级统计,每个值的数量 
int n;

void add(int i,int val){//将第i个元素增加val,其后继也要增加
    while(i<=maxn){//是x点的范围,注意不是星星的个数n 
        c[i]+=val;
        i+=lowbit(i);//i的后继(父结点) 
    }
}

int sum(int i){//前缀和 
    int s=0;
    while(i>0){
        s+=c[i];
        i-=lowbit(i);//i的前驱
    }
    return s;
}

int main(){
    scanf("%d",&n);
    int x,y;
    for(int i=0;i<n;i++){
        scanf("%d%d",&x,&y);
        x++;
        ans[sum(x)]++; 
		/*sum(x)统计横纵坐标不小于自己坐标的个数,个数就是星的等级,
		相同等级的个数累加到ans[]中 
		*/ 
        add(x,1);//x的数量c[x]增1
    }
    for(int i=0;i<n;i++)
        printf("%d\n",ans[i]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值