HDU--2054 -- A == B ? [字符串]


A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51266    Accepted Submission(s): 7924


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO
 


Code:


#include<stdio.h>
#include<string.h>
//不用考虑前导0...这让我很困惑啊..Dev结果都不对还能AC
char *removepoint(char a[])
{
	int len = strlen(a);
		//strchr的功能 : 
		//返回首次出现c的位置的指针,返回的地址是字符串在内存中
		//随机分配的地址再加上你所搜索的字符在字符串位置,如果s中不存在c则返回NULL 
	if(strchr(a,'.')!=NULL)		
	{
		while(a[--len] == '0');
		if(a[len]=='.') len--;
		a[len+1] = '\0';
	}
	return a;
}

int main()
{
	char a[15000],b[15000];
	while(~scanf("%s%s",a,b))
	{
		if(strcmp(removepoint(a),removepoint(b))==0) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值