NY--234 -- 吃土豆 [二维动态规划]

 

吃土豆

 
时间限制:1000 ms  |  内存限制:65535 KB
难度:4
  描述   Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Now, how much qualities can you eat and then get ?

 
 

输入

 

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.

输出

For each case, you just output the MAX qualities you can eat and then get.

样例输入   4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

样例输出

 242

 

Code:

 

吃掉一个土豆之后,左右的两个和上下一行的都不能吃..

这一题可以看做是两层的dp, 是求最长递增子序列的升级版

在限制条件下, 先在每一行求出最大的和,

再把这些和看做是一行,再DP一次即可

代码是在输入的时候就进行和的存储, 取i-1的值和i-1与i的和的最大值存在i里面

这样最后得到的一定是这一行的最大和

 

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b 
int val[200005],dp[200005];
int main()
{
	int r,c,i,j;
	while(scanf("%d%d",&r,&c)!=EOF)
	{
		memset(val,0,sizeof(val));
		memset(dp,0,sizeof(dp));
		for(i=0;i<r;i++)
		{
			for(j=0;j<c;j++)
			{
				scanf("%d",&val[j]);
				if(j==1) val[1] = max(val[1],val[0]);
				if(j>1)  val[j] = max(val[j-1],val[j]+val[j-2]);
			}
			dp[i] = val[c-1];
		}
		dp[1] = max(dp[0],dp[1]);
		for(i=2;i<r;i++)
			dp[i] = max(dp[i-1],dp[i]+dp[i-2]);
		printf("%d\n",dp[r-1]);		
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值