HDU 2845 Beans(最大不连续子序列和 dp)

                                                   Beans


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
  
  
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
  
  
242

题意:如图中数字81,如果81取了,那么它上面、下面的行就不能取了,左右的也不能取了。

思路:两次dp,一次行,一次列,状态方程相同dp(i)=max(dp(i-1),dp(i-2)+tmp);

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=2e5+10;
int dpx[maxn],dpy[maxn];
int main(){
	int n,m;
	while(scanf("%d%d",&m,&n)==2){
		
		memset(dpy,0,sizeof(dpy));
		for(int i=m;i>=1;i--)
		{
		 for(int j=1;j<=n;j++)
		 {int tmp;
		 scanf("%d",&tmp);
		 int t=j+2;  //因为j-2可能小于0所以整体向后移2 
		 dpy[t]=max(dpy[t-1],dpy[t-2]+tmp);
		 } 
		 dpx[i]=dpy[n+2];
		}
		
		if(dpx[2]<dpx[1])dpx[2]=dpx[1];
		for(int i=3;i<=m;i++)
		dpx[i]=max(dpx[i-1],dpx[i-2]+dpx[i]);
		
		printf("%d\n",dpx[m]);
	}
	return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值