【HDU 2069】Coin Change 暴力枚举法

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18669    Accepted Submission(s): 6460


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
  
  
11 26
 

Sample Output
  
  
4 13
 
题目大意:

有面值50、25、10、5、1分的硬币,输入钱数,用这些硬币组成这些钱,问有多少种组成方式。

注意,硬币的个数不能超过100个。
如果没漏掉这个信息基本就能对了。

#include<stdio.h>
int main()
{
    int n,a,b,c,d,e;
    while(~scanf("%d",&n))
    {
        int sum=0;
        for(a=0; a<=n; a++)
        {
            for(b=0; 5*b<=n-a; b++)
            {
                for(c=0; 10*c<=n-a-5*b; c++)
                {
                    for(d=0; 25*d<=n-a-5*b-10*c; d++)
                    {
                        e=n-a-5*b-10*c-25*d;
                        if(e%50==0&&a+b+c+d+e/50<=100)
                        //如果最后剩余的钱取余50不等于0,这种情况一定不成立
                            sum++;
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值