poj 1019 Number Sequence 二分

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34391 Accepted: 9879

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2


#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;

const ll maxn=40000;
ll a[maxn],b[maxn];
void init(){
    a[1]=b[1]=1;
    for(ll i=2;i<maxn;i++){
        a[i]=a[i-1]+(int)log10((double)i)+1;
        b[i]=b[i-1]+a[i];
    }
    return ;
}

ll f(ll m){
    ll i=1;
    while(b[i]<m)   i++;
    int p=m-b[i-1];
    int len=0;
    for(i=1;len<p;i++)
        len+=(int)log10((double)i)+1;
    return (i-1)/(int)pow((double)10,len-p)%10;
}

int main(){
    init();
    int T;
    cin>>T;
    while(T--){
        ll n;
        cin>>n;
        cout<<f(n)<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值