Number Sequence poj 1019

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest




/*#include <iostream>
#include<vector>
#include<cstdio>
#include<cmath>
using namespace std;
//vector<int>v;
const int Maxn=31269;
int a[Maxn];//第i组数字序列的长度;定义long型会超时;
int s[Maxn];//前i组数字序列的长度;
 //第i组存放的数字序列为 [1,i]的正整数,但第i组的长度不一定是i
                     //例如数字13要被看做1和3两个位,而不是一个整体
                     //打表,预先获取第2147483647个位的序列分组情况;
void play_table()
{
      a[1]=s[1]=1;
      for(int i=2;i<Maxn;i++)
      {
           a[i]=a[i-1]+(int)log10((double)i)+1; //log10(i)+1 表示第i组数字列的长度 比 第i-1组 长的位数
           s[i]=s[i-1]+a[i];//前i组的长度s[i] 等于 前i-1组的长度s[i-1] + 第i组的长度a[i]
  //log()是重载函数,必须对int的i强制类型转换,以确定参数类型
      }
      return;
}
/*计算序列第n个位置上的数字*/
/*int compute(int n)
{
     int i=1;
     while(s[i]<n) //确定整个数字序列的第n个位置出现在第i组
        i++;
     int pos=n-s[i-1];//pos为 整个数字序列的第n个位置 在 第i组中的下标值


     int len=0;
     for(i=1;len<pos;i++)
        len+=(int)log10((double)i)+1;//从第1组开始遍历第i前的每一个组,利用log10(i)+1递推第i组的长度
     return (i-1)/(int)pow((double)10,len-pos)%10;
     //之所以i-1,是因为前面寻找第i组长度时,i++多执行了一次
           //i=i-1 此时i刚好等于第n位个置上的数 (数是整体,例如123一百二十三,i刚好等于123,但n指向的可能是1,2或3)
           //pos为n指向的数字在第i组中的下标值
           //len为第i组的长度
           //那么len-pos就是第i组中pos位置后多余的数字位数
           //则若要取出pos位上的数字,就要利用(i-1)/pow(10,len-pos)先删除pos后多余的数字
           //再对剩下的数字取模,就可以得到pos
           //例如要取出1234的2,那么多余的位数有2位:34。那么用1234 / 10^2,得到12,再对12取模10,就得到2


}          //pow()是重载函数,必须对int的i强制类型转换,以确定参数类型
int main()
{
     play_table();
     int t;
     int n;
     cin>>t;
     while(t--)
     {
          cin>>n;
          cout<<compute(n)<<endl;
     }
    return 0;
}*/
#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
unsigned int a[31270],s[31270];//第i组的总数;前i组的总数;
void reset()
{
      int i;
      s[1]=a[1]=1;
      for(i=2;i<31270;i++)
      {
          a[i]=a[i-1]+(int)log10((double)i)+1;//第i组的总数;
          s[i]=s[i-1]+a[i];//前i组的总的数;
      }
}
int main()
{
     int t;
     int n;
     int i;
     scanf("%d",&t);
     reset();
     while(t--)
     {
         scanf("%d",&n);
           i=1;
           while(s[i]<n)//找到在那组;
            i++;
           int pos=n-s[i-1];//只在最后一组开始找;
           int sum=0;
           for(i=1;sum<pos;i++)
           sum+=(int)log10((double)i)+1;//递推最后一组的总的恶个数;
           int k=sum-pos;//最后一组多余的数;//例123要得到2则3是多余的元素;
         printf("%d\n",(i-1)/(int)pow(10.0,k)%10);
     }
     return 0;
}



























  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值