poj 1019 Number Sequence 两次二分

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22614 Accepted: 6031

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
 
 
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=31270+1;
const __int64 inf=2147483647;
__int64 a[maxn],cnt,sum[maxn],d[maxn];
__int64 digit(__int64 n)
{
    __int64 cnt=0;
    while(n) cnt++,n/=10;
    return cnt;
}
// 1  2  3  4  5  6  7  8  9
int binarySearch(__int64 a[],int n,__int64 key)//第一个>=key的数的位置
{
    int l=1,r=n;
    while(l<r)
    {
        int mid=(l+r)/2;
        if(a[mid]>=key) r=mid;
        else l=mid+1;
    }
    return l;
}

int main()
{
    for(int i=1;i<maxn;i++)
    {
        int dit=digit(i);
        a[i]=a[i-1]+dit;
        sum[i]=sum[i-1]+a[i];
    }
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        __int64 n;scanf("%I64d",&n);
        int p;
        p=binarySearch(sum,maxn,n);
        int pos=n-sum[p-1];
        int l=binarySearch(a,maxn,pos);
        int k=pos-a[l-1];
        string str;
        while(l) str+=l%10+'0',l/=10;
        reverse(str.begin(),str.end());
        cout<<str[k-1]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值