poj 2519 Dropping tests 二分

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6485 Accepted: 2242

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

struct node{
    double a,b,c;
}s[1005];

bool cmp(node x,node y){
    return x.c>y.c;
}

int main(){
    int n,m;
    while(cin>>n>>m){
        if(n==0&&m==0)  break;
        int i;
        for(i=0;i<n;i++) cin>>s[i].a;
        for(i=0;i<n;i++) cin>>s[i].b;

        int time=15;
        double r,l,mid;
        r=0;l=100;
        while(time--){
            mid=(r+l)/2;
            for(i=0;i<n;i++)
                s[i].c=100*s[i].a-mid*s[i].b;
            sort(s,s+n,cmp);
            double sum=0;
            for(i=0;i<n-m;i++)
                sum+=s[i].c;
            if(sum>0)  r=mid;
            else   l=mid;
        }
        printf("%.0lf\n",mid);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值