POJ 2976 Dropping tests(二分搜索,最大化平均值)


Dropping tests

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 8233


Accepted: 2883

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).


题意:在一场测试中有N项,每一项都有bi个题目,答对ai个。总的答对率就是(a1+a2+....+an-1)/(b1+b2+....+bn-1),现在可以让你从这N项测验中抽出K门不计入总的答题中,问最高答对率会是多少?


题解:二分搜索答对率,每得到一个值x,将其乘以bi,将yi=ai-bi*x,再将yi从大到小排序,看前n-k个yi的和是否大于等于0,是则表明当前x是最大答对率或小于最大答对率,否则表示当前x大于最大答对率。


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 1000000010
using namespace std;
double a[1010],b[1010];
double y[1010];
int n,k;

int cmp(double a,double b)
{
	return a>b;
}

bool dis(double x)
{
	int i;
	for(i=0;i<n;++i)
		y[i]=a[i]-x*b[i];
	sort(y,y+n,cmp);
	double sum=0;
	for(i=0;i<(n-k);++i)//注意是抽出k门课成绩不统计 
		sum+=y[i];
	return sum>=0;
} 

int main()
{
	int i;
	while(scanf("%d%d",&n,&k)&&n!=0||k!=0)
	{
		for(i=0;i<n;++i)
			scanf("%lf",&a[i]);
		for(i=0;i<n;++i)
			scanf("%lf",&b[i]);
		i=100;
		double left=0,right=INF,mid;
		while(i--)
		{
			mid=(left+right)/2;
			if(dis(mid))
				left=mid;
			else
				right=mid;
		}
		mid*=100;
		printf("%.0f\n",mid);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值