rightmost digit

竞技场测试中 可以使用acmclub各校账号登录

问题 B: Rightmost Digit

时间限制: 1 Sec
内存限制: 32 MB
提交: 105
解决: 23

题目描述

Given a positive integer N, you should output the most right digit of N^N. 
 

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

输出

For each test case, you should output the rightmost digit of N^N. 
 

样例输入

234

样例输出

76
#include <stdio.h>
int main(){
	int n,m,t,s,i,c,k;
	int a[40]={0,1,1,1,1,2,4,8,6,3,9,7,1,4,6,4,6,5,5,5,5,6,6,6,6,7,9,3,1,8,4,2,6,9,1,9,1};
	scanf("%d",&s);
	for(i=0;i<s;i++){
	scanf("%d",&n);
	 if(n%10==0){
	 	printf("0\n");
	 	continue; 
	 }
	 else{
	 	if(n>10){
	 		k = n; 
	 		n = n%10;
	        m = n%9; 
	        t = k%4;	
	
	 	}
	 	else{
	 		m = n%9;
	 		t = n%4;
	 	} 
	 }
	 
    if(m==0 && t==0){
	 m = 9;
	 t = 4;	
	}
	else if(m==0 && t!=0){
	 m = 9;	
	}
	else if(m!=0 && t==0){
	 t = 4;	
    } 
	printf("%d\n",a[(m-1)*4+t]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值