问题 B: Rightmost Digit


时间限制: 1 Sec
内存限制: 32 MB
提交: 125
解决: 31

题目描述

Given a positive integer N, you should output the most right digit of N^N. 
 

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 
 

输出

For each test case, you should output the rightmost digit of N^N. 
 

样例输入

234

样例输出

76

代码:

#include<stdio.h>




int main()
{
int n,i,N;
scanf("%d",&n);
for(i=1;i<=n;i++)
{   scanf("%d",&N);
int a=(N-1)%4;int b;
if(N%10==1) b=1;
else if(N%10==0) b=0;
else if(N%10==5) b=5;
else if(N%10==6) b=6;
else if(N%10==2) 
{
if(a==0) b=2;if(a==1) b=4;if(a==2)b=8;if(a==3) b=6; 
}
else if(N%10==3)
{
if(a==0) b=3;if(a==1) b=9;if(a==2) b=7;if(a==3) b=1;
}
else if(N%10==4)
{
if(a==0) b=4;if(a==1) b=6;if(a==2) b=4;if(a==3) b=6;
}
else if(N%10==7)
{
if(a==0) b=7;if(a==1) b=9;if(a==2) b=3; if(a==3) b=1;
}
else if(N%10==8)
{
if(a==0) b=8;if(a==1) b=4;if(a==2) b=2; if(a==3) b=6; 
}
else if(N%10==9)
{
if(a==0) b=9;if(a==1) b=1;if(a==2) b=9; if(a==3) b=1;
}
printf("%d\n",b);
}
return 0;
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值