hdoj 2719 - The Seven Percent Solution(字符串处理)

原题链接:Problem - 2719

题目描述

Uniform Resource Identifiers (or URIs) are strings like http://icpc.baylor.edu/icpc/, mailto:foo@bar.org, ftp://127.0.0.1/pub/linux, or even just readme.txt that are used to identify a resource, usually on the Internet or a local computer. Certain characters are reserved within URIs, and if a reserved character is part of an identifier then it must be percent-encoded by replacing it with a percent sign followed by two hexadecimal digits representing the ASCII code of the character. A table of seven reserved characters and their encodings is shown below. Your job is to write a program that can percent-encode a string of characters.

Character Encoding
" " (space) %20
“!” (exclamation point) %21
“$” (dollar sign) %24
“%” (percent sign) %25
“(” (left parenthesis) %28
“)” (right parenthesis) %29
“*” (asterisk) %2a

输入格式

The input consists of one or more strings, each 1–79 characters long and on a line by itself, followed by a line containing only “#” that signals the end of the input. The character “#” is used only as an end-of-input marker and will not appear anywhere else in the input. A string may contain spaces, but not at the beginning or end of the string, and there will never be two or more consecutive spaces.

输出格式

For each input string, replace every occurrence of a reserved character in the table above by its percent-encoding, exactly as shown, and output the resulting string on a line by itself. Note that the percent-encoding for an asterisk is %2a (with a lowercase “a”) rather than %2A (with an uppercase “A”).

输入样例

Happy Joy Joy!
http://icpc.baylor.edu/icpc/
plain_vanilla
(**)
?
the 7% solution
#

输出样例

Happy%20Joy%20Joy%21
http://icpc.baylor.edu/icpc/
plain_vanilla
%28%2a%2a%29
?
the%207%25%20solution

题意

将输入字符串中的指定字符用其对应的编码进行替换,其它字符不变。

字符" " (space)"!""$""%""("")""*"
对应编码%20%21%24%25%28%29%2a

编码中的字母为小写。

样例解释

以字符串 Happy Joy Joy! 为例:

原字符串Happy(space)Joy(space)Joy!
替换后Happy%20Joy%20Joy%21

单独一行 # 代表输入结束,此行不用处理。

解题思路

在输出字符串时,判断某个字符是不是需要替换的特殊字符,如果是则输出对应编码,否则原样输出。

程序代码

#include <bits/stdc++.h>
using namespace std;
int main()
{
    map<char, string> m = {
        {' ' ,"%20"},
        {'!' ,"%21"},
        {'$' ,"%24"},
        {'%' ,"%25"},
        {'(' ,"%28"},
        {')' ,"%29"},
        {'*' ,"%2a"}
    };
    string s;
    while(getline(cin, s))
    {
        if(s == "#")break;
        for(auto x : s)
        {
            if(x == ' ' || x == '!' || x == '$' ||
                x == '%' || x == '(' || x == ')' ||
                x == '*')
                cout << m[x];
            else
                putchar(x);
        }
        cout << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值