AtCoder Regular Contest 097 D - Equals

BUG反馈门

D - Equals


Time limit : 2sec / Memory limit : 1024MB

Score : 400 points

Problem Statement

We have a permutation of the integers from 1 through Np1p2, .., pN. We also have M pairs of two integers between 1 and N (inclusive), represented as (x1,y1),(x2,y2), .., (xM,yM). AtCoDeer the deer is going to perform the following operation on p as many times as desired so that the number of i (1  i  N) such that pi=iis maximized:

  • Choose j such that 1  j  M, and swap pxj and pyj.

Find the maximum possible number of i such that pi=i after operations.

Constraints

  • 2  N  105
  • 1  M  105
  • p is a permutation of integers from 1 through N.
  • 1  xj,yj  N
  • xj  yj
  • If i  j{xi,yi}  {xj,yj}.
  • All values in input are integers.

Input

Input is given from Standard Input in the following format:

N M
p1 p2 .. pN
x1 y1
x2 y2
:
xM yM

Output

Print the maximum possible number of i such that pi=i after operations.


Sample Input 1

Copy
5 2
5 3 1 4 2
1 3
5 4

Sample Output 1

Copy
2

If we perform the operation by choosing j=1p becomes 1 3 5 4 2, which is optimal, so the answer is 2.


Sample Input 2

Copy
3 2
3 2 1
1 2
2 3

Sample Output 2

Copy
3

If we perform the operation by, for example, choosing j=1j=2j=1 in this order, p becomes 1 2 3, which is obviously optimal. Note that we may choose the same j any number of times.


Sample Input 3

Copy
10 8
5 3 6 8 7 10 9 1 2 4
3 1
4 1
5 9
2 5
6 5
3 5
8 9
7 9

Sample Output 3

Copy
8

Sample Input 4

Copy
5 1
1 2 3 4 5
1 5

Sample Output 4

Copy
5

We do not have to perform the operation.


Submit


/**

题意:给定长度为n的序列 给定n次操作 x y 表示x位置可以和y位置进行交换 求解a[i]=i 的最大数量;

题解:建立领接表,对于每个节点我们对其进行访问,,对于存在边的,存在领接关系的,可以将其任意两个位置进行交换;
将其可以交换的点压入集合中,找完以该节点为起始的边后,我们对该集合进行遍历,查询a[k]确定k是否存在于set中;
 

*/

#include<bits/stdc++.h>
#define ll long long
using namespace std;
 
const int maxn=2e5+7;
int a[maxn];
bool vis[maxn];
 
vector<int>v[maxn];
set<int>s;
 
void dfs(int pos){
    vis[pos]=1;
    s.insert(pos);
    for(int k:v[pos]) if(!vis[k]) dfs(k);
}
 
int main (){
    ios_base::sync_with_stdio(false);
    int n,m;cin>>n>>m;
    memset(vis,0,(n+3)*sizeof(bool));
    for(int i=1;i<=n;i++) cin>>a[i];
    for(int i=1;i<=m;i++){
        int x,y;cin>>x>>y;
        v[x].push_back(y);
        v[y].push_back(x);
    }
    int ans=0;
    for(int i=1;i<=n;i++){
        if(!vis[i]) dfs(i);
        for(int k:s) if(s.find(a[k])!=s.end()) ans++;
        s.clear();
    }
    cout<<ans<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值