PAT : 04-树4. Search in a Binary Search Tree (25)

To search a key in a binary search tree, we start from the root and move all the way down, choosing branches according to the comparison results of the keys. The searching path corresponds to a sequence of keys. For example, following {1, 4, 2, 3} we can find 3 from a binary search tree with 1 as its root. But {2, 4, 1, 3} is not such a path since 1 is in the right subtree of the root 2, which breaks the rule for a binary search tree. Now given a sequence of keys, you are supposed to tell whether or not it indeed correspnds to a searching path in a binary search tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (<=100) which are the total number of sequences, and the size of each sequence, respectively. Then N lines follow, each gives a sequence of keys. It is assumed that the keys are numbered from 1 to M.

Output Specification:

For each sequence, print in a line "YES" if the sequence does correspnd to a searching path in a binary search tree, or "NO" if not.

Sample Input:
3 4
1 4 2 3
2 4 1 3
3 2 4 1
Sample Output:
YES
NO
NO
这道题倒是相对简单的一道题,只要知道二叉搜索树的查找顺序的特点就可以做出来了。比方说根据{1, 4, 2}这三个数,构造这样一个数列{1,0},它的意义是,当如果再要插入一个数的时候,比如3,它一定比1大,比4小,因此3就是合法的,数列就变为{1,4,2,3},再更新数列为{1,0,1},即增加条件“比2大”,接着等待下个数插入
#include <stdio.h>
#include <stdlib.h>

int main()
{
	int m, n;
	scanf("%d %d", &n, &m);
	int *numList = (int *) malloc (m * sizeof(int));
	int *lr = (int *) malloc (m * sizeof(int));
	int i, j, k, flag;

	for(i = 0; i < n; i++)
	{
		flag = 1;

		for(j = 0; j < m; j++)
			scanf("%d", &numList[j]);

		lr[0] = (numList[0] < numList[1]);

		for(j = 1; j < m; j++)
		{
			for(k = 1; k < j; k++)
			{
				if(lr[k-1] != (numList[k-1] < numList[j]))
				{
					flag = 0;
					break;
				}
			}
			
			if(flag == 0)
				break;
			
			lr[j-1] = (numList[j-1] < numList[j]);			
		}

		if(flag == 0)
			printf("NO\n");
		else
			printf("YES\n");
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值