HDU6025 Coprime Sequence (思路题)

Coprime Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 785    Accepted Submission(s): 411


Problem Description
Do you know what is called ``Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
 

Input
The first line of the input contains an integer T(1T10) , denoting the number of test cases.
In each test case, there is an integer n(3n100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers a1,a2,...,an(1ai109) , denoting the elements in the sequence.
 

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
 

Sample Input
   
   
3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8
 

Sample Output
   
   
1 2 2
 

Source
 

Recommend
jiangzijing2015   |   We have carefully selected several similar problems for you:   6032  6031  6030  6029  6028


题意
n个数,最大公约数为一,求去掉一个数,求出最大公约数
思路
从左往右,找出前几个数的最大公约数  gleft[i]
从右往左,找出后几个数的最大公约数  gright[i]
遍历,去掉第i个数时,这最大公约数为gleft[i-1]+grigh[i+1]
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
const int maxn=100010;
using namespace std;
int g[maxn];
int gleft[maxn];
int gright[maxn];
int _gcd(int a,int b)
{
    return a==0?b:_gcd(b%a,a);
}
int main()
{
    int t,n,maxnn;
     scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&g[i]);
            if(i==1)
                gleft[i]=g[i];
            else
                gleft[i]=_gcd(gleft[i-1],g[i]);
        }
        for(int i=n;i>0;i--)
        {
            if(i==n)
                gright[i]=g[i];
            else
                gright[i]=_gcd(gright[i+1],g[i]);
        }
        maxnn=0;
        for(int i=1;i<=n;i++)
        {
            if(i==1)
                maxnn=max(maxnn, gright[2]);
            else if(i==n)
                maxnn=max(maxnn,gleft[n-1]);
            else
                maxnn=max(maxnn,_gcd(gleft[i-1], gright[i+1]));
        }
        printf("%d\n",maxnn);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值