HDU6025——Coprime Sequence【数论,思维】

Coprime Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3007    Accepted Submission(s): 1390


 

Problem Description

Do you know what is called ``Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

 

 

Input

The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.

 

 

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

 

 

Sample Input

 

3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8

 

 

Sample Output

 

1 2 2

 

 

Source

2017中国大学生程序设计竞赛 - 女生专场

 

 

Recommend

jiangzijing2015   |   We have carefully selected several similar problems for you:  6343 6342 6341 6340 6339 

 

 

Statistic | Submit | Discuss | Note

题目大意:就是在一组数中删掉其中一个数,剩下的数的最大公约数是多少。

题目思路:首先我们知道要求一组数据的最大公约数,就是求着组数据的第n个数,和前n-1个数的公约数,因此我们可以用个数

组 来记录第N个数之前的数的公约数,(用递推的方式计算),在求第N个数的后面所有的数的公约数,然后删除当前数据就是求第N个数的前n-1个数和后N+1个数的公约数。

#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int MAXN=1e5+7;
int qian[MAXN],hou[MAXN],a[MAXN];
int gcd(int a,int b){
    if(b==0) return a;
    else{
        return gcd(b,a%b);
    }
}
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d",&a[i]);
        qian[0]=a[0];
        //0~a[i]的gcd
        for(int i=1;i<n;i++){
            qian[i]=gcd(qian[i-1],a[i]);
        }
        //a[i]~n-1的所有gcd
        hou[n-1]=a[n-1];
        for(int i=n-2;i>=0;i--){
            hou[i]=gcd(hou[i+1],a[i]);
        }
        int maxx=max(hou[1],qian[n-2]);
        for(int i=1;i<n-1;i++){
            maxx=max(maxx,gcd(qian[i-1],hou[i+1]));
        }
        printf("%d\n",maxx);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值