由二叉树的后序和中序求层次遍历

PAT 1020

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2

题意:给出后序和中序,求出层次遍历

#include <cstdio>
#include <cstring>
#include <queue>
#include <iostream>
using namespace std;
const int maxn=50;
struct node                     //节点 
{
	int date;
	node* ld;
	node* rd;
} ;
int pre[maxn],in[maxn],post[maxn];
int n;         //节点个数 
node* create(int postl,int postr,int inl,int inr)    //由后序和中序构建一颗树 
{
	if(postl>postr)      
	return NULL;
	node* root=new node;              //建立一个新的节点,存放当前二叉树的根节点         
	root->date =post[postr];          //新节点的数据域为当前根节点的值 
	int k;
	for(k=inl;k<=inr;k++)
	{
		if(in[k]==post[postr])
		break;
	}
	int numleft=k-inl;              //左子树的节点个数 
	root->ld =create(postl,postl+numleft-1,inl,k-1);
	root->rd =create(postl+numleft,postr-1,k+1,inr);
	return root;
}
int num=0;                          //已经输出的节点个数,便于空格输出
void bfs(node* root)
{
	queue<node*> q;
	q.push(root);
	while(!q.empty()  )
	{
		node* now=q.front() ;
		q.pop() ;
		printf("%d",now->date );
		num++;
		if(num<n) printf(" ");	
		if(now->ld !=NULL) q.push(now->ld );
		if(now->rd !=NULL) q.push(now->rd );
		  
	 } 
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)   //后序输入 
	scanf("%d",&post[i]);
	for(int i=0;i<n;i++)  //中序输入 
	scanf("%d",&in[i]);
	node* root=create(0,n-1,0,n-1);   
	bfs(root);           //层序输出 
	return 0;
}
  

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值