1056 Mice and Rice (25 分) 复杂模拟 题意

1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

The second line contains NP  distinct non-negative numbers Wi
没说整数 

注意理解题意
The second line contains NP distinct non-negative numbers Wi(i=0,...,NP-1)  
a permutation of 0,...,NP1 (assume that the programmers are numbered from 0 to NP-1)

第二行的顺序第一个为0号选手  第2个位1号选手
第三行是选手号i  而不是对应选手的参赛次序
    eg:6 0 8指的是6号第一个  0号第二个   8号第三个   也即6 0 8号选手一组 

英语不好千万细心点,注意括号内的解释,对应的字母在前面哪出现过 
 

一路瞎搞...弄了好长时间,特别复杂,最后自己都快看不懂了。。。可.....竟然一次通过了。。

#include<bits/stdc++.h>
using namespace std;
int N, G, id, Index = 0, maxN, ans[1010];
double wi[1010], comp[1010];
map<double, int> Hash;
struct Cat {
	int id, order, out;
}cat[1010];
bool compare(Cat a, Cat b) {return a.order>b.order;}
bool compare2(Cat a, Cat b) {return a.id<b.id;}

int main() {
	//	freopen("in.txt","r",stdin);
	cin >> N >> G;
	for (int i = 0;i<N;i++) {
		cin >> wi[i];
		Hash[wi[i]] = i;
	}
	for (int i = 0;i<N;i++) {
		cin >> id;
		comp[i] = wi[id];
	}
	maxN = N;
	while (maxN>1) {
		int num = 0;
		for (int i = 0;i<maxN;i += G) {
			int NM = min(i + G, maxN);
			int x = max_element(comp + i, comp + NM) - comp;
			for (int j = i;j<NM;j++) {
				if (j != x) ans[Hash[comp[j]]] = Index;//都是第同一轮
			}
			comp[num++] = comp[x];
		}
		Index++;
		maxN = num;
	}
	ans[Hash[comp[0]]] = Index++;//最后胜利的人剩下一个
	for (int i = 0;i<N;i++) {
		cat[i].id = i;cat[i].order = ans[i];
	}
	sort(cat, cat + N, compare);
	int T = 1;
	for (int i = 0;i<N;i++) {
		cat[i].out = i + 1;
		if (i>0 && cat[i].order == cat[i - 1].order) cat[i].out = cat[i - 1].out;
	}
	sort(cat, cat + N, compare2);
	for (int i = 0;i<N;i++) {
		if (i>0) cout << " ";
		cout << cat[i].out;
	}
	return 0;
}

 

整理了下,不过感觉还是看不懂。。纯瞎搞....

#include<bits/stdc++.h>
using namespace std;
int N, G, id, Index = 0, maxN;
double wi[1010], comp[1010];
map<double, int> Hash;
struct Cat {
	int id, order, out;
}cat[1010];
bool compare(Cat a, Cat b) { return a.order>b.order; }
bool compare2(Cat a, Cat b) { return a.id<b.id; }
int main() {
	cin >> N >> G;
	for (int i = 0;i<N;i++) {
		cin >> wi[i];
		Hash[wi[i]] = i;
	}
	for (int i = 0;i<N;i++) {
		cin >> id;
		comp[i] = wi[id];
	}
	maxN = N;
	while (maxN>1) {
		int num = 0;
		for (int i = 0;i<maxN;i += G) {
			int NM = min(i + G, maxN);
			int x = max_element(comp + i, comp + NM) - comp;
			for (int j = i;j<NM;j++) {
				if (j != x) {
					int np = Hash[comp[j]];
					cat[np].order = Index;//都是第同一轮
					cat[np].id = np;
				}
			}
			comp[num++] = comp[x];
		}
		Index++;
		maxN = num;
	}
	//最后胜利的人剩下一个
	int np = Hash[comp[0]];
	cat[np].order = Index;//都是第同一轮
	cat[np].id = np;
	sort(cat, cat + N, compare);
	int T = 1;
	for (int i = 0;i<N;i++) {
		cat[i].out = i + 1;
		if (i>0 && cat[i].order == cat[i - 1].order) cat[i].out = cat[i - 1].out;
	}
	sort(cat, cat + N, compare2);
	for (int i = 0;i<N;i++) {
		if (i>0) cout << " ";
		cout << cat[i].out;
	}
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值