Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.
First the playing order is randomly decided for N~P~ programmers. Then every N~G~ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N~G~ winners are then grouped in the next match until a final winner is determined.
For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N~P~ and N~G~ (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N~G~ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N~P~ distinct non-negative numbers W~i~ (i=0,…N~P~-1) where each W~i~ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,…N~P~-1 (assume that the programmers are numbered from 0 to N~P~-1). All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
题型:模拟,可用数组也可以用vector
#include <bits/stdc++.h>
using namespace std;
struct node
{
int num;
int index;
}a[10020];
map<int,std::vector<int> > mymap;
int ans[10020];
int lun(int n,int k){
if(n%k==0) return n/k;
else return n/k+1;
}
int main(){
int N,K;
cin>>N>>K;
for(int i=0;i<N;i++){
cin>>a[i].num;
}
for(int i=0;i<N;i++){
cin>>a[i].index;
}
for(int i=0;i<N;i++){
mymap[1].push_back(a[i].index);//第一行
}
int now=1;
while(mymap[now].size()!=1){
int l=lun(mymap[now].size(),K);//计算当前行的轮次,即group个数
for(int i=1;i<=l;i++){
int m=-1;
int in=0;
for(int j=(i-1)*K;j<=i*K-1&&j<mymap[now].size();j++){//每一个group内部比较
ans[mymap[now][j]]=l+1; //一定会有l人晋级,那剩下的人rank为l+1
if(m<a[mymap[now][j]].num){//更新冠军的大小
m=a[mymap[now][j]].num;
in=mymap[now][j];//记录index
}
}
mymap[now+1].push_back(in);//在下一行存放冠军
}
now++;//移动到下一行
}
ans[mymap[now][0]]=1; //冠军元素特殊处理
int flag=0;
for(int i=0;i<N;i++){
if(!flag){
printf("%d",ans[i]);
flag=1;
}
else{
printf(" %d",ans[i]);
}
}
printf("\n");
return 0;
}