1079 Total Sales of Supply Chain (25 分) 树遍历 DFS BFS

1079 Total Sales of Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then Nlines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目太长,饶了一大圈,读起来费劲,其他都还好 
N很大 但是DFS可以  我还是习惯用bfs,那么就都用BFS吧,毕竟没有递归 

第一眼感觉优先选择DFS,但是看结点个数10^5,怕超时就用了BFS,毕竟BFS比较熟,果然一次就过了。其实DFS也行,更加简单,且没有超时

#include<bits/stdc++.h>
using namespace std;
int n;
double p,r,ans=0;
struct node{
	int data,layer;
	vector<int> child;
}Node[100010];

void dfs(){
	queue<int> q;
	Node[0].layer=0;
	q.push(0);
	while(!q.empty()){
		int top=q.front();
		q.pop();
		if(Node[top].child.size()==0){//叶子结点 
			ans+=p*pow(1+r/100.0,Node[top].layer)*Node[top].data;
		}else{
			vector<int> c=Node[top].child;
			for(int i=0;i<c.size();i++){
				Node[c[i]].layer=Node[top].layer+1;
				q.push(c[i]);
			}
		}
	}
}

int main(){
//	freopen("in.txt","r",stdin);
	cin>>n>>p>>r;
	int N,x;
	for(int i=0;i<n;i++){
		scanf("%d",&N);
		if(N!=0){
			while(N--){
				scanf("%d",&x);
				Node[i].child.push_back(x);
			}	
		}else{
			scanf("%d",&x);
			Node[i].data=x;
		}
	}
	dfs();
	printf("%.1f",ans);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值