1079 Total Sales of Supply Chain (25分)

题目

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P P P and sell or distribute them in a price that is r r r% higher than P P P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N ( ≤ 1 0 5 ) N(\le10^5) N(105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N − 1 N−1 N1, and the root supplier’s ID is 0); P P P, the unit price given by the root supplier; and r r r, the percentage rate of price increment for each distributor or retailer. Then N N N lines follow, each describes a distributor or retailer in the following format:

K i I D [ 1 ] I D [ 2 ] . . . I D [ K i ] K_i ID[1] ID[2] ... ID[K_i] KiID[1]ID[2]...ID[Ki]

where in the i i i-th line, K i K_i Ki is the total number of distributors or retailers who receive products from supplier i i i, and is then followed by the ID’s of these distributors or retailers. K j K_j Kj being 0 means that the j j j-th member is a retailer, then instead the total amount of the product will be given after K j K_j Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1 0 10 10^{10} 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目大意

给出一条供应商到销售商的供应链,约定条件最起始的供应商为0号,且中间商不零售,商品没流通一环,价格上涨 r r r倍,要求输出零售商的所有销售额之和。

解题思路

画出供应链图,很明显这是树的结构,所以按照树的层次遍历计算,每当层次增加,价格上涨相应倍数,当遍历到叶节点时计算销售额;

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;

const int MAXN = 100000;

struct Node{
    int data;
    vector<int> next;
};

int main(){
    int n;
    double p, r;
    vector<Node> v;
    scanf("%d %lf %lf", &n, &p, &r);
    v.resize(n);
    for(int i=0, t; i<n; i++){
        scanf("%d", &t);
        if(t > 0){
            for(int j=0, d; j<t; j++){
                scanf("%d", &d);
                v[i].next.push_back(d);
            }
        }
        else{
            scanf("%d", &v[i].data);
        }
    }
    queue<int> que;
    double ans = 0.0;
    que.push(0);
    while(!que.empty()){
        int t = que.size();
        for(int i=0; i<t; i++){
            int temp = que.front();
            for(int j=0; j<v[temp].next.size(); j++)
                que.push(v[temp].next[j]);
            if(v[temp].next.empty()){
                ans += p*v[temp].data;
                //printf("%d %d %lf %lf\n", temp, v[temp].data, p, ans);
            }
            que.pop();
        }
        p *= (1 + r*0.01);
    }
    printf("%.1lf\n", ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值