【标记】HDU3466 Proud Merchants (0-1背包)

12 篇文章 0 订阅

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5865    Accepted Submission(s): 2461


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 

Author
iSea @ WHU
 

Source
 

本题题目大意如下:有n种商品和m元,商人的价格为p, iSea 评估的价格为v,若要购买该商品,则余额要不少于q,输出最后能得到的最大价值,由v组成。假设有A,B两种商品,分别为A:p1,q1;B:p2,q2。若要先A后B,则要余额为p1+q2;若要先B后A,则要余额为p2+q2。从暴力的角度来考虑,如果要A优先B,则存在p1+q2 <  p2+q1,有因为暴力和动态规划是逆过程,所以在以动态规划求解中,若要A优先B,则是p1+q2  > p2+q1,变形可得q1-p1 < q2-p2.按此进行排序,然后按照0-1背包递推公式进行求解即可。


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

struct node{
	int p,q,v;
}P[505];

int n,m,dp[5005];

int cmp(node A, node B){
	return A.q - A.p < B.q - B.p;
}

void ZeroOnePack(int p, int q, int v){
	for(int i = m; i >= q; i --)
		dp[i] = max(dp[i],dp[i - p] + v);
}

int main(){	
	while(~scanf("%d%d",&n,&m)){
		for(int i = 1; i <= n; i ++)
			scanf("%d%d%d",&P[i].p,&P[i].q,&P[i].v);
		
		sort(P + 1, P + n + 1,cmp); 
		memset(dp,0,sizeof(dp));
		
		for(int i = 1; i <= n; i ++)
			ZeroOnePack(P[i].p,P[i].q,P[i].v);
		
		printf("%d\n",dp[m]);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值