HDU1423 Greatest Common Increasing Subsequence (LICS)

33 篇文章 1 订阅

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7433    Accepted Submission(s): 2391


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2
 

Source


思路:最长递增公共子序列的模板题目

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

int a[505],b[505],dp[505],n,m,t;

int LICS(){
	int MAX;
	
	for(int i = 1; i <= n; i ++){
		MAX = 0;
		for(int j = 1; j <= m; j ++){
			if(a[i-1] > b[j-1] && MAX < dp[j])
				MAX = dp[j];
			if(a[i-1] == b[j - 1])
				dp[j] = MAX + 1;
		}
	}
	
	MAX = 0;
	for(int i = 1; i <= m; i ++)
		MAX = max(dp[i],MAX);	
	return MAX;
}

int main(){
	scanf("%d",&t);
	
	while(t --){
		scanf("%d",&n);
		for(int i = 0; i < n; i ++)
			scanf("%d",&a[i]);
		scanf("%d",&m);
		for(int j = 0; j < m; j ++)
			scanf("%d",&b[j]);
		
		memset(dp,0,sizeof(dp));
		printf("%d\n",LICS());
		
		if(t)
			printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值