POJ1703 Find them, Catch them(并查集+向量偏移)

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 44767 Accepted: 13791

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


题意:给出两个人,判断是否属于同一个团伙,D表示两人不属于同一个团伙,A表示请求判断两人是否是同一团伙。

思路:这道题目是并查集+向量偏移,偏移量为0表示两者是同一团伙,偏移量为1表示两者不是同一团伙,当两者的根节点不相同时,即不属于同一团伙时,两者之间的偏移量为1,详细代码如下:


另外要注意:cin输入的话会超时,应为cin的输入时间是scanf的好几倍。

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int par[100005],Rank[100005];

int find_set(int x){
    if(x == par[x])
        return x;
    int t = par[x];
    par[x] = find_set(par[x]);
    Rank[x] = (Rank[x] + Rank[t]) % 2;//判断当前结点与根节点的偏移量
    return par[x];
}

void UnoinSet(int u, int v){
    int x = find_set(u);
    int y = find_set(v);

    if(x != y){
        par[y] = x;
        Rank[y] = (2 + 1 - Rank[v] + Rank[u]) % 2;//因为两者的不属于一个团伙,所以u->v的偏移量为1
    }
}

int main(){
    int t,n,m;
    scanf("%d",&t);
    while(t --){
        scanf("%d%d",&n,&m);

        for(int i = 1; i <= n; i ++){
            par[i] = i;
            Rank[i] = 0;
        }

        char ch;
        int u,v;
        getchar();
        for(int i = 1; i <= m; i ++){
            scanf("%c%d%d",&ch,&u,&v);

            if(ch == 'D')
                UnoinSet(u,v);
            else{
                int x = find_set(u);
                int y = find_set(v);

                if(x != y){//两者不属于同一个集合,则说明两者的关系不能够确定
                    printf("Not sure yet.\n");
                }
                else{
                    int r = (2 + Rank[v] - Rank[u]) % 2;//计算u和v之间的偏移量
                    if(r == 0)//表示两者是一个团伙
                        printf("In the same gang.\n");
                    else
                        printf("In different gangs.\n");
                }
            }
            getchar();
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值