HDU2844 Coins

12 篇文章 0 订阅

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14198    Accepted Submission(s): 5649


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
 

Source
 
思路:题目的大意为有n个钱币,第i个钱币的价值为v[i],数量为c[i],一个手表的价钱最大不超过m,求这些钱币能够表示小于等于m的数目。

一道多重背包题目,最后计算出能够放进背包的所有可能的结果即可。


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int v[105],b[105],n,m,vis[100005],f[100005];

void ZeroOnePack(int weight, int cost){
    for(int v = m; v >= cost; v --){
        f[v] = max(f[v],f[v-cost]+weight);
    }
}

void CompletePack(int weight, int cost){
    for(int v = cost; v <= m; v ++){
        f[v] = max(f[v],f[v-cost]+weight);
    }
}

void MultiplePack(int weight, int cost, int amount){
    if(cost * amount >= m){
        CompletePack(weight,cost);
    }
    else{
        for(int k = 1; k < amount; k *= 2){
            ZeroOnePack(k*weight,k*cost);
            amount -= k;
        }
        ZeroOnePack(amount*weight,amount*cost);
    }
}

int main(){
    while(~scanf("%d%d",&n,&m)){
        if(!m && !n)
            break;

        for(int i = 0; i <= m; i ++){
            f[i] = vis[i] = 0;
        }

        for(int i = 0; i < n; i ++){
            scanf("%d",&v[i]);
        }
        for(int i = 0; i < n; i ++){
            scanf("%d",&b[i]);
        }

        for(int i = 0; i < n; i ++){
            MultiplePack(v[i],v[i],b[i]);
        }

        int cnt = 0;
        for(int i = 1; i <= m; i ++){//记录有哪些小于等于m的数字出现
            vis[f[i]] ++;
        }
        for(int i = 1; i <= m; i ++){//判断小于等于m的数字是否出现
            if(vis[i])
                cnt ++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值