HDU2844-Coins(多重背包 二进制优化 模板)

题目链接

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10

1 2 4 2 1 1

2 5

1 4 2 1

0 0

Sample Output

8

4


题意

多重背包,每个物品给了固定的数量。

思路

多重背包可以看做是01背包+完全背包

01背包 和 完全背包的比较

01背包逆序,完全背包顺序。

对于多重背包,如果物品数量足够多,多到你用不完,就已经装满了,其实可以看成是完全背包。如果有几个相同的物品,可以看成是几个独立的,转化为01背包。

关于01背包的二进制优化,比如有17个相同的物品,可以看成1,2,4,8,2的01背包。因为1,2,4,8,2这五个数可以组成任意的1-17的数,如果看成17个独立的物品,1,1,...,1,1,会很费时间。


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define ll long long
#define inf 0x3f3f3f3f

using namespace std;
const int N = 200010;

int dp[N];
int c[N],w[N],num[N];
int n,m;

void ZeroOne_Pack(int cost,int weight,int n)
{
    for(int i=n; i>=cost; i--)
        dp[i] = max(dp[i],dp[i-cost] + weight);
}

void Complete_Pack(int cost,int weight,int n)
{
    for(int i=cost; i<=n; i++)
        dp[i] = max(dp[i],dp[i-cost] + weight);
}

int Multi_Pack(int c[],int w[],int num[],int n,int m)
{
    memset(dp,0,sizeof(dp));
    for(int i=1; i<=n; i++)
    {
        if(num[i]*c[i] > m)
            Complete_Pack(c[i],w[i],m);
        else{
            int k = 1;
            while(k < num[i]){
                ZeroOne_Pack(k*c[i],k*w[i],m);
                num[i] -= k;
                k <<= 1;
            }
            ZeroOne_Pack(num[i]*c[i],num[i]*w[i],m);
        }
    }
    return dp[m];
}

int main()
{
    while(~scanf("%d%d",&n,&m),n+m)
    {
        for(int i=1;i<=n; i++) cin>>w[i];
        for(int i=1;i<=n; i++) cin>>num[i];
        Multi_Pack(w,w,num,n,m);
        int ans = 0;
        for(int i=1;i<=m;i++){
            if(dp[i]==i) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值