HDU5974 A Simple Math Problem (韦达定理)

 

A Simple Math Problem

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1683    Accepted Submission(s): 489

 

 

Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b

 

 

Input

Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.

 

 

Output

For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).

 

 

Sample Input

 

6 8 798 10780

 

 

Sample Output

 

No Solution 308 490

 

 

Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)

 

 

 

 

思路:设gcd(x,y) = m;则令i = x/m,j=y/m;

则可得{i*m + j*m = a; i * j * m = b};即可得 i + j = a/m, i * j = b/m。令a /= m, b /= m;

设一个一元二次方程 Ax^2 + Bx + c ; 则x1 + x2 = -B/A, x1 * x2 = C/A; 所以a == B, b == C, A == 1;

因为i和j互质,所以i+j 和 i*j也互质, 所以gcd(x,y) == gcd(a,b); 

详细代码如下:

 

 

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

int gcd(int a, int b){
	if(a < b)
		swap(a,b);
	return b ? gcd(b,a%b) : a;
}

int main(){
	int a,b;
	while(~scanf("%d%d",&a,&b)){
		int m = gcd(a,b);
		int temp = a;
		a /= m; b /= m;
		
		if(a*a - 4*b < 0){
			printf("No Solution\n");
		}
		else{
			int ans = (a + sqrt(a*a - 4*b)) / 2;
			ans *= m;
			int cnt = temp - ans;
			if(cnt * ans / gcd(cnt,ans) == b * m){
				printf("%d %d\n",cnt,ans);
			}
			else
				printf("No Solution\n");
		}
	}
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值