POJ1328 Radar Installation (贪心)

 

Radar Installation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 87179 Accepted: 19538

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

 
Figure A Sample Input of Radar Installations

 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

Beijing 2002

 

 

思路:这道题目的难点在于如何把给定的已知条件,转化成相对熟悉的方法来求解。已知存在雷达和岛屿,要求用最少的雷达数目来覆盖全部的岛屿,如果存在不能够覆盖掉的,则输出-1,否则输出需要的最少的雷达数目。题目中岛屿的个数以及坐标都是固定的,要求的是雷达的数目,所以就可以以岛屿的坐标为圆心,以雷达扫描半径为圆的半径,画圆,然后求出圆和x轴的交点,如果两个圆和x轴的交点有重合,则说明这两个岛屿可以共用一个雷达,所以只需要求出以岛屿为圆心的圆与x轴的两个交点即可,以这两个交点为区间,然后求区间的重叠即可,

 

 

AC代码如下:

 

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

int n,d;
struct node{
    int x,y;
    double disl,disr;
}p[1005];

bool cmp(node A, node B){
    if(A.disl == B.disl)
        return A.disr < B.disr;
    return A.disl < B.disl;
}

int main(){
    int ans = 1;
    while(~scanf("%d%d",&n,&d)){
        if(n == 0 && d == 0)
            break;

        int flag = 0;
        for(int i = 0; i < n; i ++){
            scanf("%d%d",&p[i].x,&p[i].y);
            if(p[i].y > d)//判断是否存在大于雷达半径的岛屿
                flag = 1;
        }

        if(flag){//存在大于雷达半径的岛屿,直接输出-1即可
            printf("Case %d: -1\n",ans++);
            continue;
        }

        for(int i = 0; i < n; i ++){
            double dist = sqrt(d * d - p[i].y * p[i].y);//勾股定理求以该岛屿为圆心与x轴交点的横坐标
            p[i].disl = -dist + p[i].x;
            p[i].disr = dist + p[i].x;//求当前区间的左右端点
        }

        sort(p,p+n,cmp);//按照左端点进行排序

        int cnt = 1;
        double r = p[0].disr;//记录第一个区间的右端点
        for(int i = 1; i < n; i ++){
            if(p[i].disl > r){//当前区间的左端点大于以前某区间的右端点,则说明不重叠,雷达数目+1,更新右端点
                cnt ++;
                r = p[i].disr;
            }
            else if(p[i].disr < r){//跟新右端点,使得右端点的值最小,因为只有在某一区间内相交的区间最多,雷达数目才能够最少
                r = p[i].disr;
            }

        }
        printf("Case %d: %d\n",ans++,cnt);
    }
    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值