POJ3616 Milking Time (dp)

33 篇文章 1 订阅
9 篇文章 0 订阅

Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10738 Accepted: 4507

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source



题意:有m个区间,FJ每次挤牛奶就必须在一个完整的区间内,并且两次挤奶的时间间隔要大于等于r,求能够挤的最多的奶。

思路:dp[i]表示时间为i时能够挤的最多的奶的数量,把区间按照左端点排序,依次遍历,dp[i] = max(dp[i],mxx+p[i].eff);

注意:max()不能存在+号之类的数组,不然会出错。。。。


代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 1e6 + 10;
int dp[maxn],n,m,r,mxx;
struct node{
	int start,end,eff;
}p[maxn];

bool cmp(node A, node B){
	if(A.start == B.start) return A.end < B.end;
	return A.start < B.start;
}

int main(){
	while(~scanf("%d%d%d",&n,&m,&r)){
		for(int i = 0; i < m; i ++){
			scanf("%d%d%d",&p[i].start,&p[i].end,&p[i].eff);
		}
		sort(p,p+m,cmp);
		memset(dp,0,sizeof(dp));
		for(int i = 0; i < m; i ++){
			mxx = -1;
			for(int j = 0; j < i; j ++){
				if(p[i].start - r >= p[j].end){
					mxx = max(dp[p[j].end],mxx);
				} 
			}
			if(mxx == -1) dp[p[i].end] = p[i].eff;
			else mxx += p[i].eff,dp[p[i].end] = max(dp[p[i].end],mxx);
		}
		mxx = dp[p[0].end];
		for(int i = 0; i < m; i ++){
			mxx = max(dp[p[i].end],mxx);  
		} 
		printf("%d\n",mxx);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值