zoj3203 Light Bulb(三分)

Problem Description
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H,h and D in one line. H is the height of the light bulb whileh is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, andH - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
简单的公式推导。影长L=地上的+墙上的。当影子头部恰好在墙角时最长,故是凸函数,先增大后减小。设墙上的影长为x从光线照到墙上的点做水平线即得公式,这样一来墙上有和没有都包含了。
#include<cstdio>
#include<cmath>
#define eps 1e-6
double H,h,D;
double f(double x)
{
	return (h-x)*D/(H-x)+x;
}
int main()
{
	int t;
	double r,l,mid1,mid2,x1,x2;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf%lf",&H,&h,&D);
		l=0;
		r=h;
		while(r-l>eps)
		{
			mid1=(r+l)/2;
			mid2=(mid1+r)/2;
			if(f(mid2)<f(mid1))
				r=mid2;
			else
				l=mid1;
		}
		printf("%.3f\n",f(l));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值