HDU 1009 FatMouse' Trade 贪心菜鸟题

FatMouse' Trade

Time Limit: 1 Sec   Memory Limit: 64 MB
Submit: 203   Solved: 160
[ Submit][ Status][ Discuss]

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

HINT


贪心顾名思义就是寻求最多的某个东西,即问题为如何获得最多的东西。本题要求用最少的A获得最多的B,也就是要求兑换率最高,于是问题转化为将兑换率按从高到低进行排序。
代码如下:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct food{
    int cat;
    int java;
    double eff;
};
bool cmp(struct food p,struct food q)
{
    if(p.eff==q.eff)
        return p.cat<q.cat;
    return p.eff>q.eff;
}

int main()
{
    struct food food[1005];
    int i,p,j,x,f,q;
    double y;
    while(scanf("%d%d",&j,&f)!=EOF)
    {
        if(j==-1&&f==-1)
            break;
        for(i=0;i<=1004;i++)
        {
            food[i].cat=0;
            food[i].java=0;
            food[i].eff=0;
        }
        for(i=0;i<f;i++)
        {
            scanf("%d",&food[i].java);
            scanf("%d",&food[i].cat);
            food[i].eff=(double)food[i].java/food[i].cat;
        }
        sort(food,food+f,cmp);
        y=0;
        for(i=0;i<f;i++)
        {
            j-=food[i].cat;
            if(j>=0)
                y+=food[i].java;
            else
            {
                j+=food[i].cat;
                y+=food[i].eff*j;
                break;
            }
        }
        printf("%.3lf\n",y);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值