1012 The Best Rank (25 分)【最好的排序】

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题意:从四门课选一个最好的排名,然后查询每一个人最好排名,注意的是排名是1 2 3 3 5的这种

解题思路:用数据结构存储需要的信息(id,成绩数组,每一门成绩的排名的数组,最好成绩的排名的下标),在外面再定义一个数组,题目说明是6位数,所以定义数组大小为10000000,初始都是0,在后面处理的时候会将id的那个值改为i+1,我们先把每一门成绩的排名弄出来,外面循环是0到3(排序,先将第一个人的成绩排名为1),里面循环是0到n,每一个人的排名先赋值为i+1,然后判断是不是与上一个人的成绩一样,如果是再将上一个成员的排名赋值给它。最后就判断m个id是否不为0,做出相应的打印。

#include<bits/stdc++.h>
using namespace std;
int judge[10000000];
int flag=-1;
string s="ACME";
struct Rank{
	int id;//学生id 
	int grade[4];//成绩 
	int rank[4];//每一项成绩排名 
	int best;//最佳排名位置 
}stu[2005];
bool cmp(Rank a,Rank b)
{
	return a.grade[flag]>b.grade[flag];
}
int main(void)
{
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++)
	{
		scanf("%d %d %d %d",&stu[i].id,&stu[i].grade[1],&stu[i].grade[2],&stu[i].grade[3]);
		stu[i].grade[0]=(stu[i].grade[1]+stu[i].grade[2]+stu[i].grade[3])/3.0+0.5;
		//judge[stu[i].id] = i + 1;
	}
	for(flag=0;flag<=3;flag++)
	{
		//cout<<flag<<endl;
		sort(stu,stu+n,cmp);
		stu[0].rank[flag]=1;
		for(int i=1;i<n;i++)
		{
			stu[i].rank[flag]=i+1;
			if(stu[i].grade[flag]==stu[i-1].grade[flag]) stu[i].rank[flag]=stu[i-1].rank[flag];
		}
	}
	for(int i=0;i<n;i++)
	{
        judge[stu[i].id] = i + 1;
		int minv=stu[i].rank[0];
		stu[i].best=0;
		for(int j=1;j<=3;j++)
		{
			if(stu[i].rank[j]<minv) 
			{
				minv=stu[i].rank[j];
				stu[i].best=j;
			}
		}
	}
	for(int i=0;i<m;i++)
	{
		int id;
		scanf("%d",&id);
		if(judge[id]==0) printf("N/A\n");
		else
		{
			int temp=judge[id]-1;
			int best = stu[temp].best;
			//cout<<best<<endl;
			printf("%d %c\n",stu[temp].rank[best],s[best]);
		}
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值