1012 The Best Rank (25 分)(结构体排序)

 

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
题意:是对四个成绩进行排名,c语言,数学,英语,以及三门的平均分(只需要把三门加起来存到结构体即可,反正都要除以三)。用sort,自己写了个cmp函数,排名需要特别注意的一点,成绩相同的名次也相同,
就是说比如88 87 87 55,对应名次为1,2,2,4。
#include <iostream>
#include <map>
#include <algorithm>
using namespace std;
int w=1;
struct st
{
    string id;
    int c,m,e,a;
    int cc,mm,ee,aa;
} s[2010];
bool cmp(st a,st b)
{
    if(w==1)return a.c>b.c;
    else if(w==2)return a.m>b.m;
    else if(w==3)return a.e>b.e;
    else return a.a>b.a;
}
void print(st a)
{
    char ch='A';
    int b=a.aa;
    if(b>a.cc)b=a.cc,ch='C';
    if(b>a.mm)b=a.mm,ch='M';
    if(b>a.ee)b=a.ee,ch='E';
    cout<<b<<" "<<ch<<endl;
}
int main()
{
    map<string,int>p;
    int n,m;
    cin>>n>>m;
    for(int i=0; i<n; i++)
    {
        cin>>s[i].id>>s[i].c>>s[i].m>>s[i].e;
        s[i].a=s[i].c+s[i].m+s[i].e;
    }
    sort(s,s+n,cmp);
    for(int i=0; i<n; i++)
    {
        if(i>0&&s[i].c==s[i-1].c)s[i].cc=s[i-1].cc;
        else s[i].cc=i+1;
    }
    w=2;
    sort(s,s+n,cmp);
    for(int i=0; i<n; i++)
    {
        if(i>0&&s[i].m==s[i-1].m)s[i].mm=s[i-1].mm;
        else  s[i].mm=i+1;
    }
    w=3;
    sort(s,s+n,cmp);
    for(int i=0; i<n; i++)
    {
        if(i>0&&s[i].e==s[i-1].e)s[i].ee=s[i-1].ee;
        else s[i].ee=i+1;
    }
    w=4;
    sort(s,s+n,cmp);
    for(int i=0; i<n; i++)
    {
        if(i>0&&s[i].a==s[i-1].a)s[i].aa=s[i-1].aa;
        else s[i].aa=i+1;
        p[s[i].id]=i+1;
    }
    for(int i=0; i<m; i++)
    {
        string c;
        cin>>c;
        if(p[c])print(s[p[c]-1]);
        else cout<<"N/A"<<endl;
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值