00-自测4. Have Fun with Numbers (20)

原文链接:http://www.patest.cn/contests/mooc-ds/00-%E8%87%AA%E6%B5%8B4

00-自测4. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

#include <stdio.h>
#include <string.h>
int oriDigit[20], resDigit[20];
void ToDigit(char *s, int n) {
	for(int i = 0; i < n; ++i)
		oriDigit[i] = s[i] - '0';
	return;
}
void Double(int n) {
	for(int i = 0; i < n; ++i)
		resDigit[i] = 2 * oriDigit[i];
	for(int i = n - 1; i > 0; --i) {
		resDigit[i - 1] += resDigit[i] / 10;
		resDigit[i] %= 10;
	}
	return;
}
int Check(char *s, int n) {	//检查数字是否满足要求 
	ToDigit(s, n);			//将字符串数字转化为整数 
	Double(n);				//将整数 加倍 
	for(int i = 0; i < n; ++i)
		for(int j = 0; j < n; ++j)
			if(oriDigit[i] == resDigit[j]) {	//将已经 相等的数字做标记:减去10变成负数 
				resDigit[j] -= 10;
				break;
			}
	for(int i = 0; i < n; ++i)
		if(resDigit[i] >= 0)
			return 0;
	return 1;
}
int main() {
	char s[20];
	gets(s);
	int len = strlen(s);
	if(Check(s, len)) {
		printf("Yes\n");
		for(int i = 0; i < len; ++i) {
			if(resDigit[i] < 0)	 
				resDigit[i] += 10;
			printf("%d", resDigit[i]);	
		}
	}
	else {
		printf("No\n");
		for(int i = 0; i < len; ++i) {
			if(resDigit[i] < 0)
			resDigit[i] += 10;
			printf("%d", resDigit[i]);
		}
	}
	
	return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值