04-树5. File Transfer (25)

04-树5. File Transfer (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.

#include <stdio.h>
#include <stdlib.h>
int findSet(int *set, int val) {		//返回所在树的根节点
	while (set[val] >= 0) {
		val = set[val];
	}
	return val;
}
void unionSet(int *set, int c1, int c2) {	//按大小求并
	int root1 = findSet(set, c1);
	int root2 = findSet(set, c2);
	if (set[root1] < set[root2]) {	//树1更大,将树2连接到树1根节点
		set[root1] += set[root2];
		set[root2] = root1;
	}
	else {
		set[root2] += set[root1];
		set[root1] = root2;
	}
}
int main() {
//	freopen("test.txt", "r", stdin);
	int n;
	scanf("%d", &n);
	int *set = (int *)malloc(sizeof(int) * (n + 1));
	for (int i = 0; i <= n; ++i) {	//初始化树大小,根节点负值,其绝对值表示树大小
		set[i] = -1;
	}
	char ch;
	scanf("\n%c", &ch);
	while (ch != 'S') {
		int c1, c2;
		scanf("%d%d", &c1, &c2);
		if (ch == 'I') {
			unionSet(set, c1, c2);		//c1,c2所在集合求并
		}
		else if(ch == 'C') {
			if (findSet(set, c1) == findSet(set, c2)) {
				printf("yes\n");
			}
			else {
				printf("no\n");
			}
		}
		scanf("\n%c", &ch);
	}
	int cnt = 0;
	for (int i = 1; i <= n; ++i) {		//计算根节点个数
		if (set[i] < 0) {
			++cnt;
		}
	}
	if (cnt == 1) {
		printf("The network is connected.\n");
	}
	else {
		printf("There are %d components.\n", cnt);
	}
	free(set);

	return 0;
}


题目链接:http://www.patest.cn/contests/mooc-ds/04-%E6%A0%915
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值