PAT 数据结构 04-树5. File Transfer (25)

输入包含一个网络中电脑的数量N和它们的连接情况。测试用例包括建立连接、检查文件传输可能性和结束。对于每个检查请求,若能从c1到c2传输文件则输出'yes',否则输出'no'。最后,输出网络是否完全连接或存在几个连通组件。
摘要由CSDN通过智能技术生成

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.
/*2015.7.11*/
// 图的连通及优化,7月20日才知道这是并查集
#include <iostream>
using namespace std;

int root[10002];
//这么写会超时。。。
//int findroot(int a){
//	if(root[a]!=a)
//		a=findroot(root[a]);
//	return a;
//}
int findroot(int a){
	if(root[a]!=a)
		root[a]=findroot(root[a]);路径压缩,更新为根结点的子结点
	return root[a];
}
int main(){
	int N;
	scanf("%d",&N);
	for(int i=1;i<=N;i++)
		root[i]=i;   //记录每个结点所能连接到的最大节点序号
	char ch;
	int a,b;
	scanf("%c",&ch);
	while(ch!='S'){
		scanf("%d%d",&a,&b);
		if(ch=='I'){
			int ar=findroot(a);
			int br=findroot(b);
			if(ar!=br){
				N--;
				if(ar<br)
					root[ar]=br;
				else
					root[br]=ar;
			}
		}
		if(ch=='C'){
			if(findroot(a)==findroot(b)){
				printf("yes\n");
			}else
				printf("no\n");
		}
		scanf("%c",&ch);
	}
	if(N==1)
		printf("The network is connected.\n");
	else
		printf("There are %d components.\n",N);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值